Page 12 of 15 FirstFirst ... 2456789101112131415 LastLast
Results 111 to 120 of 150

Thread: Frankie's 86 GT build

  1. #111
    Classic Member

    Join Date
    Nov 2011
    Location
    Dundas, Ontario
    Posts
    859
    Heads are hogged out E7s.

    I'm not interested in going carb.....

  2. #112
    New Member dave silva 1980 fox's Avatar

    Join Date
    Dec 2015
    Location
    oakville/ burglinton
    Posts
    47
    Humm... what rear gear.?
    Mercury capri 5.0 with a little spray

  3. #113
    New Member dave silva 1980 fox's Avatar

    Join Date
    Dec 2015
    Location
    oakville/ burglinton
    Posts
    47
    If you have 273's that would make it hard to spin tires.
    Mercury capri 5.0 with a little spray

  4. #114
    Classic Member

    Join Date
    Nov 2011
    Location
    Dundas, Ontario
    Posts
    859
    LOL
    2.73s will spin them, no prob.

    This has 3.55s in it. That comment was meant to indicate how low the power is

  5. #115
    Fox FiXXXer Chimney's Avatar

    Join Date
    Jan 2016
    Location
    York Region
    Posts
    1,500
    Quote Originally Posted by dave silva 1980 fox View Post
    What heads do you have? My opinion if your staying all motor go carb.
    @ St Thomas Raceway Park

    🦊

  6. #116
    Classic Member

    Join Date
    Nov 2011
    Location
    Dundas, Ontario
    Posts
    859
    Been pretty busy since i came back from my last trip.
    Got my brothers 87 done and out of my shop (motor swap and 5 lug conversion).
    Been working on the new-to-us pool to keep the kids happy and i'm finally getting back to the 86.

    Swapped the fuel pump tonight - no rust sure makes things easier!




    Had a little help from my garage buddy to get it back in:


    Unfortunately i got done just as the rain came down hard here.
    Started her up and it was still the same. Popping and backfiring thru the intake on startup.

    As a last ditch effort, i swapped in the entire stock MAF i have in the shop and presto! runs great.
    Previously i had just replaced the electronics. Not sure why my 73mm C&L housing doesn't work? It ran great in the 89.
    Will have to wait for the test drive tomorrow for the final verdict.
    Either way, i'm finally going in the right direction. Its about time.

  7. #117
    GTAMC Executive 99chromegt's Avatar

    Join Date
    Sep 2012
    Location
    Dundas
    Posts
    10,118
    It was your good luck charm / shop helper's doing I bet lol. Fingers crossed for you. Great update

  8. #118
    Classic Member

    Join Date
    Nov 2011
    Location
    Dundas, Ontario
    Posts
    859
    So after all the hype I took it out for a drive and it runs better but still not right.
    Next on the list is a set of known good injectors and a new pressure reg.
    Very frustrated right now

  9. #119
    New Member dave silva 1980 fox's Avatar

    Join Date
    Dec 2015
    Location
    oakville/ burglinton
    Posts
    47
    Buy brand new injectors ..hows your fuel pump.?
    Mercury capri 5.0 with a little spray

  10. #120
    New Member P71nick's Avatar

    Join Date
    May 2014
    Location
    Toronto
    Posts
    5
    Very nice build. What kind of tail pipes are on the car?

Page 12 of 15 FirstFirst ... 2456789101112131415 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •